Skip to Content.
Sympa Menu

h5part - Re: [H5part] Patch#1 : Win32 compiler support

h5part AT

Subject: H5Part development and discussion

List archive

Re: [H5part] Patch#1 : Win32 compiler support

Chronological Thread 
  • From: John Biddiscombe <biddisco AT>
  • To: Achim Gsell <achim.gsell AT>, h5part AT
  • Subject: Re: [H5part] Patch#1 : Win32 compiler support
  • Date: Thu, 10 May 2007 08:52:21 +0200
  • List-archive: <>
  • List-id: H5Part development and discussion <>

With this definition _h5get_errno() expands to something different than you set with _h5set_errno(a). "_errno" is an internal H5Part error number but "errno" is the system error number! It might be the best to rename "_errno" to something like "_h5part_errno" ...

With above definition the patch
- return _errno;
+ return _h5get_errno();

is wrong!
Aha. I probably didn't see an underscore and missed the distinction. Confusingly on win32 the system defines
#define errno (*_errno())

Which is nice!

Is it your intention to use only the h5part _errno or the system errno - if you are not using the system errno at all, then the problem is much simpler and we simply call the variable _h5errno and the need for win32 specific #defines goes away.

I was just getting my next patch ready too. Now I'll have to back everything up and start again.


Archive powered by MHonArc 2.6.19.

Top of Page